Recientemenete me he visto necesitado de una versión de PHP superior a la 5.2.4 que venía instalada con el paquete de apache por defecto de Apple.

Para mantener la estructura del módulo de Apple, en lugar de bajar los fuentes desde la página de PHP y compilar con las opciones de mi actual distribución, he optado por buscar algún paquete pre-compilado para instalar… y no ha sido fácil 😦

En la web http://www.entropy.ch/software/macosx/php/ disponen de un paquete más actualizado que el mío (yo tengo la 5.2.4 y aquí tienen la 5.3.0-3), pero no suficiente para usar Symfony2 (necesito al menos la versión 5.3.2)

Googleando un poco, encuentro un hilo (https://discussions.apple.com/thread/2376521?start=15&tstart=0) donde encuentro las siguientes instrucciones que voy siguiendo:

(más…)